yat  0.19pre
Deprecated List
Member theplu::yat::classifier::MatrixLookup::MatrixLookup (const utility::Matrix &matrix, const utility::Index &index, const bool row_vectors)
Provided for backward compatibility with the 0.6 API. Use MatrixLookup(const utility::Matrix&, const utility::Index&, const utility::Index&)
Member theplu::yat::classifier::MatrixLookup::MatrixLookup (const MatrixLookup &ml, const utility::Index &, const bool row_vectors)
Provided for backgroundColor compatibility with the 0.6 API. Use MatrixLookup(const MatrixLookup&, const utility::Index&, const utility::Index&)
Member theplu::yat::classifier::MatrixLookupWeighted::MatrixLookupWeighted (const MatrixLookupWeighted &ml, const utility::Index &, const bool row_vectors)
Provided for backward compatibility with the 0.6 API. Use MatrixLookupWeighted(const MatrixLookupWeighted&, const utility::Index&, const utility::Index&)
Member theplu::yat::classifier::Target::operator[] (size_t sample) const
Provided for backward compatibility with the 0.4 API. Use operator().
Member theplu::yat::omic::BamFile< Derived >::open_base (const std::string &fn, const std::string &mode, const void *aux)
Provided for backward compatibility with the yat 0.17 API. Use open_base(2) instead.
Member theplu::yat::omic::BamRead::cigar (const std::vector< uint32_t > &c)
Provided for backward compatibility with 0.11 API. Use cigar(const utility::Aligner::Cigar&) instead.
Member theplu::yat::random::Continuous::seed (unsigned long s) const
Provided for backward compatibility with the 0.7 API. Use RNG::instance()->seed(s) instead.
Member theplu::yat::random::Continuous::seed_from_devurandom (void)
Provided for backward compatibility with the 0.7 API. Use RNG::instance()->seed_from_devurandom() instead.
Member theplu::yat::random::Discrete::seed (unsigned long s) const
Provided for backward compatibility with the 0.7 API. Use RNG::instance()->seed(s) instead.
Member theplu::yat::random::Discrete::seed_from_devurandom (void)
Provided for backward compatibility with the 0.7 API. Use RNG::instance()->seed_from_devurandom() instead.
Member theplu::yat::statistics::Fisher::p_value_one_sided () const
Provided for backward compatibility with the 0.10 API. Use p_right() instead.
Member theplu::yat::statistics::PearsonCorrelation::p_value_one_sided (void) const
Provided for backward compatibility with the 0.10 API. Use p_right(void).
Member theplu::yat::statistics::percentile (RandomAccessIterator first, RandomAccessIterator last, double p, bool sorted=false)
percentile2 will replace this function in the future
Member theplu::yat::statistics::ROC::p_value_one_sided (void) const
Provided for backward compatibility with 0.10 API. Use p_right() instead.
Member theplu::yat::statistics::tTest::p_value_one_sided (void) const
Provided for backward compatibility with 0.10 API. Use p_right() instead.
Member theplu::yat::utility::is_double (const std::string &)
Provided for backward compatibility with the 0.4 API. Use is<double>(const std::string&)
Member theplu::yat::utility::is_float (const std::string &)
Provided for backward compatibility with the 0.4 API. Use is<float>(const std::string&)
Member theplu::yat::utility::is_int (const std::string &)
Provided for backward compatibility with the 0.4 API. Use is<int>(const std::string&)
Class theplu::yat::utility::OptionInFile
Provided for backward compatibility with the 0.5 API. Use OptionFile and StreamRedirect instead (see CommandLine for example code).
Class theplu::yat::utility::OptionOutFile
Provided for backward compatibility with the 0.5 API. Use OptionFile and StreamRedirect instead (see CommandLine for example code).
Class theplu::yat::utility::Range< T >
Provided for backward compatibility with the 0.12 API. Use Boost Range class instead, which provides a more extensive interface.
Member theplu::yat::utility::SmithWaterman (const utility::Matrix &s, double gap, double open_gap)
Provided for backward compatibility with 0.8 API. Use Aligner::smith_waterman() instead.

Generated on Mon Jan 18 2021 02:25:54 for yat by  doxygen 1.8.11